Cadê o meu plugin do Java?

Se você está se perguntando onde está o pacote sun-java6-jre ou o sun-java6-plugin no Ubuntu 10.04, fique tranquilo, existe uma explicação (tradução livre):

Java da Sun movido para o repositório Partner

No Ubuntu 10.04 LTS, os pacotes sun-java6 foram removidos da seção Multiverse do Ubuntu archive. É recomendado que você use o  openjdk-6.

Se você não pode trocar o Sun JDK/JRE proprietário para o OpenJDK, você pode instalar os pacotes sun-java6 pelo repositório Partner da Canonical. Você pode configurar seu sistema para usá-lo via linha de comando:

sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"

Fonte: ubuntu.com

Obs: O openjdk não deu conta da página do Banco do Brasil…

11 opiniões sobre “Cadê o meu plugin do Java?”

  1. André,

    Sou cliente do Banco do Brasil e passei maior aperto ao tentar usar o ForesightLinux para acessar minha conta. Nele o java proprietário chama-se Ice-Tea. Demorei um bom tempo até entender que o java do repositório não era o que eu buscava.

    Acho que essa de mudar de nome ou tirar do repositório padrão, deixando para o usuário final descobrir a pegadinha, será um tremendo tiro no pé da usabilidade que já é precária no linux.

    Link: http://www.foresightlinux.org

  2. Cara, eu concordo com isso…

    E se o openjdk é bom no nível que eles dizem (e free), já deveria vir instalado para não ter esse problema de assustar o usuário.

    Abração, Zé!

  3. Peraí, se eu der um upgrade do meu 9.10 pro 10.04 vai sumir o JRE e o JDK (já que programo em Java tb)? :(

    Droga!

  4. Fernando,

    Acredito que por ter sido você quem instalou, e se instalou o pacote sun-java6, ele não vai desinstalar na atualização.

    Mas se instalou pelo pacote ubuntu-restricted-extras, é possível que ele troque pelo openjdk. Mas daí você faz a mágica do post.

    Abraços.

  5. Eu uso o site do banco do brasil e, por isso, preciso do sun java6. Digitei tudo conforme vc ensinou: add-apt-repository “deb http://archive.canonical.com/ lucid partner”.

    Só que aparece o seguinte erro: “Error: must run as root”. Alguém pode me ajudar? Agradeço muito!!

  6. Oi Emerson,

    Use o “sudo” antes. Fica assim:

    sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"

    Vou corrigir no texto.

    Abraços.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *